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Introduction
Setting up an online store for your website has got to be one of the trickiest 
things that you can undertake. Dealing with people's money, tracking orders, 
product fulfilment and maintaining a good trading reputation are all 
paramount concerns.

Thankfully there are online solutions available that offer shopping cart 
functionality that you can simply link your product pages to for either a 
minimal charge or, with some, for free. One of the easiest to use and most 
versatile is Mal's e-commerce. The brainchild of Mal Stewart, the site offers 
both free and subscription based shopping cart services that allows you to get 
selling online quickly and securely.

To start trading you will need;

• Some web space to host your shopping pages
• An account at Mal's e-commerce (www.mals-e.com)
• Either a way of processing the orders manually or an online 

payment processor (such as PayPal, Nochex, Verisign or 
WorldPay)

The Mal's free account will collect the order and credit card details and save 
them securely, allowing you to process the payments manually. The premium 
(paid for) account, however, seamlessly integrates with a number of existing 
payment processors allowing you to automate payment collection.

On signing up for an account you will receive an e-mail outlining your account 
settings and details on how you can access the secure administration part of 
the Mal's website. From this page you can maintain your account details, view 
the orders that have come in from buyers, and alter the cart options available 
to your store (using the Cart set-up link). It's worth spending some time 
reading through the extensive documentation on the site in regard to setting 
up costs for shipping units, tax, affiliate programmes, language settings. This 
also covers the visual side of the shopping cart including options for changing 
the logo, colours, fonts etc.

The Mal's E-Commerce Suite is a set of actions that allows Freeway users to 
easily add the anything from simple 'buy now' links to quite complex multi-
option purchase forms to their web sites.



Using the Actions
The Mal's action suite contains the following eight individual actions;

• Mal's Buy Button
Use this action to add simple 'buy now' buttons to your shopping pages.

 
• Mal's Buy Form Setup
Either sketch this action around all of the form items that make up a single 
product order or attach it to a parent object (a table or a page for example) 
and it will group the items together and define them ready for Mal's.

 
• Mal's Buy Image Link
With similar functionality to the Mal's Buy Button action this action allows 
you to set up 'buy now' buttons based on images.

 
• Mal's Buy Text Link
Create a simple text link that users can click on to add the product to the 
shopping cart.

 
• Mal's Multiprice Select
For product forms with different prices for different options (a wool coat 
may be $100.00 but the leather version may cost $150.00 for example) 
the Mal's Multiprice Select action can add the correct code to achieve quite 
complex buying options.

 
• Mal's Quantity Field/Checkbox/Radio
Again for form based product pages this action allows you to easily set up 
all of the required attributes associated with quantity fields, checkboxes and 
radio buttons.

 
• Mal's Review Cart Image Link
Much like the Mal's Buy Image Link action this can be applied to an existing 
image that will allow your site visitors to review the contents of their 
shopping cart.

 
• Mal's Review Cart Text Link
This action allows you to easily set up text based links to allow your site 
visitors to review the contents of their shopping cart.

 



The Action Interface - an Example
Most of the actions in the suite share a common core functionality and simply 
allow you to apply this in different situations. Here we will be looking at the 
Mal's Buy Form Setup action.

Mal's Buy Form Setup action interface



The Activate check box is something that you will find in a lot of these 
actions as it allows action code to be disabled without needing to be removed 
from the item which would, in turn, lose any of the user settings applied to it. 
It allows users to quickly add and remove action functionality very quickly and 
easily.

Below the Activate check box are the main controls for the action starting 
with the Link info section.

The Server address pop-up menu allows you to select the server at Mal's 
that your shopping cart is located on. To date there are six servers that 
process orders with each dealing with transactions specifically for users with 
user IDs within a certain range. By splitting the load like this you can be 
assured that things won't grind to a halt if everyone goes shopping at the 
same time. Simply select from the menu the name of the server you were 
given when you signed up with Mal's and which should be outlined in your 
welcome e-mail. If the name of the server is missing from the list then simply 
select Other... at which point a new text field will appear below this menu 
allowing you to either type or paste the address of the server into it.

Most of the time, I suspect, the Target menu will go unused. It allows you, 
however, to open the Mal's shopping cart page up in a defined location, be it a 
frame or a window. Select from the standard _parent, _top, _blank and 
_self options, or none at all (which is the same as _self). The Other... 
option allows you to define the name of the target the page should be opened 
into by entering it's name in the Other target text field. If the target is 
available the page will be loaded into it or, if unavailable, a new browser 
window will be created and given this name.
The next section, Buy info, contains all of the remaining information about 
the store and the products themselves.

The User ID field should contain your Mal's account ID number that you were 
given when you first signed up for the account. This is the only way that the 
server has of knowing which shopping cart to add the products to so make 
sure it is correct. Ideally you should copy and paste this from your welcome e-
mail. Once a user ID has been entered in one action all of the other 
subsequently applied actions will use this value by default.

Product name contains the descriptive text that your users will see in the 
main shopping cart window for each product. Ideally this should be short, to 
the point and descriptive of the item in question. If you later add further 
options for the product, such as colours or sizes, these will be appended to the 
end of this description in the cart window.



The Price field contains the unit price for the item without any currency 
signs. The currency to be used in the cart is defined by a setting in the cart 
administration page on the Mal's web site.

The remainder of the controls in the action are all optional so if you are in a 
hurry to can skip these and still have a functioning shopping cart. However we 
would strongly recommend that you spend the extra time working with these 
features as they will not only make your store easier for visitors to use but 
add important features that will help protect your site from malicious use. To 
enable these features use the Optional info checkbox.

If you wish to add multiple items to the shopping cart for each click (maybe 
you would like to offer 3 items for the price of 2) then you can do so by 
specifying the number in the Quantity field. By default the system will add a 
single item to the shopping cart each time the item is clicked unless another 
value is specified either here or in another quantity field in your form.

The Return to text field, when specified, allows the shopping cart to return 
the user directly back to the page they last viewed. You will need to specify 
the address of either the current page or a page that you wish the user 
should return to (maybe an offers page) as an absolute URL. For example;
http://www.mydomain.com/shop/item1.html

If the product is a physical item that needs to be shipped or posted then you 
will need to specify how much the user has to pay for this. Once again this is 
handled by the secure administration section of the Mal's web site. These 
codes can then be entered into the action using the Shipping units entry 
field.

The Language pop-up menu allows you to specify the language the user will 
see the shopping cart page displayed in including both European and US 
English.

The Currency ID field allows you to specify the currency the user will see in 
the shopping cart. These options can be set up in the secure administration 
section of the Mal's web site.

If your goods are subject to tax then you can specify the percentage to charge 
for each product by entering a figure in the Tax field.

Link verification is a very powerful part of the Mal's shopping cart and is 
also a feature built into these actions. To prevent users from manually 
altering the code that makes up your shopping pages each product is marked 



with a special encoded identification number that denotes the product, any 
additional extras and the price. If the shopping cart receives an order where 
the information in the link or button does not match this identification 
number then the item order is refused.

OK, so now we've covered the core of the action's interface elements lets start 
by creating set of sample 'buy now' links that will allow you to add items to 
your Mals cart.

Creating Simple 'Buy Now' Links
The simplest and most direct method of allowing your site visitors to purchase 
items is to use 'buy now' links. These are standard HTML links to the Mal's 
shopping cart that contain the reference to the product, quantity, price etc. 
On clicking the link the shopping cart page is called and the item information 
is automatically added to the cart. 'Buy now' links can either take the form of 
HTML text or image links.

The following examples assume you are fairly familiar with Freeway's ability to 
create pages as well as uploading these using the application's built in FTP 
tool.

Creating Text Links

Before you look at adding any e-commerce functionality to your website it's 
worth getting the pages as developed as you can. Design and produce the 
layouts you want and leave gaps for the text links. When you are happy with 
the overall design and functionality of the site you can start to add the 'buy 
now' links.

Select an HTML text box in your design and place the cursor where you want 
the text link to appear in the run of text. Select Action Item > Mal's Buy 
Text Link from the Insert menu.

Inserting the Mal's Buy Text Link action into a run of styled text

This will insert an action item into the run of text. Click on this item to select it and 
choose Window > Actions to show the action's palette if it's not already visible. It is 



here that you will see all of the options for the action.

The Mal's Buy Text Link action interface (in part)

Ensure the Enabled checkbox at the top of the action palette is ticked. This allows you 
to quickly turn the action on and off without having to remove and destroy the action 
instance. If you ever need to temporarily remove any of these actions from your pages 
then simply use this control.

Using the account information you should have been e-mailed when you first signed 
up for your Mal's account as a guide set the Server address menu to the correct 
setting for your account. If the server address isn't present in the menu then simply 
select other and enter the address in the text field that becomes available.

Next, type in the text you want to appear in the web page in the Link text field. In the 
Buy info section of the action enter your user ID as well as the name of the item you 
are selling in the Product name field. Finally enter the price of the item in the Price 
field. Remember not to add anything other than a numerical value in here as the 



currency itself is set using the secure admin panel of the Mal's cart.

If you now preview your site in a web browser with a live internet connection you 
should be able to click on this link to add the item directly into your Mal's cart account.
Although we've skipped over many of the options within the action these are the basics 
of setting up the action for a simple text based buy link. For information on using these 
options please see the Advanced Features section later in this document.

Creating Image Links

The process of creating image links is almost identical to that outlined above 
in the creating text links section.

Attaching the Mal's Buy Image Link action to an image

Sketch a picture box to your Freeway page and either import your desired 
image or create one using the application or one of the Graphics Pack FAST 
actions. With the picture box selected add the Mal's Buy Image Link action 
to it by either selecting Actions > Mal's Buy Image Link from the Item 
menu or by clicking on the apply new action icon at the foot of the action's 
palette and selecting the action from the list.

Use the apply new action button to add the Mal's Buy Image Link action to an image.

Once applied you will be able to modify the action's setting by using the 
controls in the action's palette.



The Mal's Buy Image Link action interface (in part)

You will notice that the interface for this action is almost identical to that of 
the text link action we used in the previous example. The only difference 
between the two, in fact, is that you can't set the link text of an image link 
(for obvious reasons) and therefore this field is missing from the action 
interface.

Again, follow the steps outlined in the text link example. Set the Server 
address, User ID, Product name and Price. For now that is all we are going 
to set in this basic example although the Advanced Features section later in this 
document outlines how you can use the rest of the features to enhance the buy link.
Publish your page and, assuming you have a live internet connection, click on this 
image link to see the product automatically added to your Mal's shopping cart.



Creating Review Cart Links
We've seen how we can quickly and easily add items to our shopping cart by 
way of both text and image links but one thing we are still missing is a 'review 
cart' link. A review cart text or image link allows your site visitors to see the 
contents of the shopping cart without having to add further items to it. The 
Mal's Review Cart Text Link and Mal's Review Cart Image Link actions are 
almost identical in functionality to their 'buy' action counterparts that we've 
already seen. The only difference is that these actions do not contain any 
product information or price fields.

The Mal's Review Cart Image Link action interface (in part)

For a text based review link select your HTML text box and place the cursor 
where you want the review link to appear in the run of text. Select Action 
Item > Mal's Review cart Text Link from the Insert menu.
Alternatively to set up an image based review cart link simply sketch a picture 
box to your Freeway page and either import your desired image. With the 
picture box selected add the Mal's Review Cart Image Link action to it by 
either selecting Actions > Mal's Review Cart Image Link from the Item 
menu or by clicking on the apply new action icon at the foot of the action's 
palette and selecting the action from the list. Once again in the actions palette 



set the Server address and User ID if not already set1.

1 When you first enter your server and user ID information into any of the Mal's actions they are 
stored in a document wide setting. This means that when you next add another Mal's action to your 
document it is these setting that are used by default. By automatically populating these settings you 
can concentrate on the values that change from item to item and not on those that remain the same 
throughout the site.

A Review Cart Image Link in action

Creating Simple Buy Forms
Functionally simple form items are very similar to the 'buy now' links we have 
seen on the preceding pages, except here the data is posted using an HTML 
form rather than a text or image link. Again, each button for a product adds 
that product to the cart, and as many products as you like can be put on a 
page this way.

Using the form button tool

Using the form button tool from the tool palette sketch a button to your page 



and add the add the Mal's Buy Button action to it by selecting Actions > 
Mal's Buy Button from the Item menu. Alternatively click on the apply new 
action icon at the foot of the action's palette and selecting the action name 
from the list.

Give the button a suitable title by clicking on the button tab of the inspector 
palette and add the text in the value field. You can leave the type as submit 
although the action will set this value regardless of what is set here.

Adding a value to the button using the Inspector palette

Set the Server address menu to the correct setting for your account. In the Buy 
info section of the action enter your user ID as well as the name of the item you are 
selling in the Product name field. Finally enter the price of the item in the Price field. 
Remember not to add anything other than a numerical value in here as the currency 
itself is set using the secure admin panel of the Mal's cart.
Preview your site, click this button and the item will be added into your Mals cart.

The Mal's Buy Button action applied to a form button



Creating Advanced Buy Forms
Unlike the examples we have seen so far advanced forms allow you to build a 
shopping cart solution specifically tailored to the needs of the item in question. 
Rather than adding single items to the cart one at a time advanced forms 
allow your shoppers to customize each item purchased to their own needs. 
For example you may want to let your shoppers specify the size or color of an 
item. With advanced forms you can do this and more.

Example 1: Single Product with Options

Either sketch an HTML text box or table from the tool palette and apply the 
Mal's Buy Form Setup action to it by either selecting Actions > Mal's Buy 
Form Setup from the Item menu or by clicking on the apply new action icon 
at the foot of the action's palette and selecting the action from the list. This 
text box or table will define the boundaries of the form and should enclose all 
of your form elements for this item.

Using the actions palette enter the Server address and User ID for this 
form. The product description and price is not required in the action as these, 
in this instance, are handled by the form elements we are about to add to this 
form.
 

The single product with options form items

To this enclosing text box or table we are going to add two select lists that will 
define the products and options. The functionality you require from your final 
form item will define what form elements you use within this area.
In our example we will add two select lists by selecting Menu/List from the 
Insert menu for each item. Select each of these in turn and apply the Mal's 
Multiprice Select action.

Using the controls in the action palette set the Product number popup menu 
to 1. You can set this value from 1 to 30 and it denotes which product the 



values below this control relate to.

Why would you want to set the product number to anything other than 1? By 
adding a number of multiprice selects to a form like this and setting their 
values in the actions palette you can build quite complex forms that, at the 
click of the submit button, will add anything up to 30 items to the user's 
shopping cart at any one time. Although adding such a high number of items 
in one hit like this is rather excessive it should illustrate just how complex and 
involved your buy forms can become should you wish.

The Mal's Multiprice Select action interface



For the moment we are going to use the Item sections of the action to fill in 
the options for this menu item. Under Item 1 enter 'small' in the Choice field 
and 'small' again in the Description field. Repeat this technique for the next 
four Item blocks inserting 'medium', 'large', 'huge' and finally, 'painful' into the 
fields Choice and Description.

Choice is the text that will appear in the menu item and Description is the 
text that will appear in the shopping cart once the form has been submitted 
to the Mal's server.

It is in this action that you can also, optionally, set the price and shipping 
units for each item in the list. If, for example, your product is normally 
$40.00 but the large size is $45.00 then you would set the prices using this 
action rather than in the parent form item action. If all of the options are the 
same price then simply use the parent Mal's Buy Form Setup action to 
define a price for all of the options.

Click on the second of the two select lists as we are now going to add the 
values for that item in the actions palette.

Again select 1 as the Product number as these are settings are additions to 
the existing sizes we set previously in the first select list.

Add three products to this item by entering the options outlined in the 
following screen shot.

Technically the price isn't required in the Choice text field but is here as a 
courtesy to the buyer as without it they wouldn't know what the price is for 
the option.

What we have done here is to add the main products to the second select list 
with their associated descriptions and prices and have used the first select list 
for supplementary information - in this case the item size. We could have 
defined these select lists the other way around and got exactly the same 
results. As we saw earlier we could keep adding options to the form and as 
long as we define them as Product 1 it will simply add another option to the 
same product. We could, for example, extend the current buy form to add a 
select list that allows the user to select a product color.

Finally add a standard form button to the text box (or table) and make sure 
that its type is set to submit.



Adding the product names & prices in the Mal's Multiprice Select action

Publish your site and try the form. Select the size and color of the speakers  (if 
you are following our example) and click the Add to Cart button to see the 
item, and it's options, appear in the Mal's cart.



Example 2: Multiple Products by Quantity

Moving on from the first example in this example we are going to allow our 
buyers to select the number of items of each product they want to purchase.

The completed form from example 2

Start off by sketching an enclosing HTML text box big enough to hold your 
form elements and apply the Mal's Buy Form Setup action by selecting 
Actions > Mal's Buy Form Setup from the Item menu.

Using the actions palette enter the Server address and User ID for this 
form. Again the product description and price is not required in the action as 
these, yet again, are handled by the form elements we are about to add to 
this form.

Into this text box add a standard HTML text field by selecting the Insert > 
Text Field menu. To this apply the Mal's Quantity Field/Checkbox/Radio 
action item from the Item > Actions menu. As you might have guessed this 
action is specifically for applying to, and modifying, text fields, checkboxes and 
radio buttons.

In the action palette set the default quantity value for the text field in the 
Quantity field and the Product number. The checkbox Use info in parent 
form should be unchecked as we decided not to add the product information 
in there (the enclosing HTML text box) but to put in in using this action.

Add the Product name and Price to the action.
Repeat the process for the second quantity field but this time set the Product 
popup menu to 2 as we are defining the second product in the form. Again set 
the Product name and Price for this second item. Finally add a standard form 
button into the text box by selecting the Button item from the Insert menu.
Preview the page, enter the quantities required and click on the Add to Cart 
button to see the item, and the correct quantities, appear in the Mal's cart.



The Mal's Quantity Field/Checkbox/Radio action interface

Example 3: Multiple Products with Options and Quantities

In this example we'll be moving on from the concepts we've explored in the 
previous examples by allowing the user to not only define the quantities but 
also a range of options for each item. These options can either be free or may 
add to the product's base price. For example a jacket may be available at 
$50.00 in all sizes apart from extra large where it is sold for $60.00.
In this example we'll be looking at basketball sneakers in various sizes and 
colors.

The Multiple Products with Options and Quantities form from example 3



Once again start by sketching an enclosing HTML text box big enough to hold 
your form elements and apply the Mal's Buy Form Setup action by selecting 
Actions > Mal's Buy Form Setup from the Item menu.

Use the actions palette to enter your Mals Server address and User ID for 
this form. Unlike the previous example we are going to add the product 
description and price to this enclosing action item. This will have the effect of 
setting a base price and description for all the items this form contains. From 
here we can choose to override this base value at any point using any of the 
'child' form elements should we wish.

We'll first add a simple line of text into this text box that tells the user the 
product name and price. Click inside the text box and enter "Basketball Sneakers 
Price: $150".
On the next line enter "Size:" followed by a standard HTML select list by 
selecting the Insert > Menu/List menu item. Apply the Mal's Multiprice 
Select action item from the Item > Actions menu.

Using the controls in the action palette set the Product number popup menu 
to 1. You can set this value from 1 to 30 and it denotes which product the 
values below this control relate to. For the time being we'll be adding the 
details for the first product in this form. Set the choice and description in 
the action palette but leave the rest of the items empty as these values will 
be automatically picked up from the parent form item we've already set up. 
Adding values to any of these fields will override the value held in them parent 
form for this item only. So, for example, if the Product number popup menu is 
set to 1 and choice number one in your select list is priced at $180.00 rather 
than the $150.00 you set in the parent Mal's Buy Form Setup then this is 
the price this item will be set at. Be aware that the user will have no idea that 
this item is priced differently to any other option in this form unless you 
choose to tell them by using the description field of the Mal's Multiprice 
Select action.

Repeat the process by adding another select list to the text box for the color of 
the sneakers and again apply the Mal's Multiprice Select action item from the 
Item > Actions menu.

Finally (for this first product) add a standard HTML text field by selecting the 
Insert > Text Field menu. To this apply the Mal's Quantity Field/Checkbox/
Radio action item from the Item > Actions menu. In the action palette set 
the default quantity value for the text field in the Quantity field and set the 
Product number to 1. The checkbox Use info in parent form should be 
checked as we want this product information that we entered in the enclosing 



HTML text box to be used.

OK, so we've successfully added the first pair of sneakers to this form and now 
need to repeat the process for the second pair. Rather than repeating the 
whole process over again it is a lot simpler, and quicker, to simply select 
everything in this text box with Edit > Select All and Copy and Paste this 
below product number 1.

Click on each of the form elements that make up product number 2 and set 
the Product number in the action's palette accordingly.
Because our tennis sneakers are more expensive than the basketball sneakers 
we'll have to modify the Mal's Quantity Field/Checkbox/Radio action applied to 
the quantity field at the end of this product. Simply select the quantity field 
and making sure the Use info in parent form checkbox is unchecked set 
the new Product name and Price in the action's palette.

Finally add a standard form button into the text box by selecting the Button 
item from the Insert menu. 
Preview the page in any web browser, enter the quantities required and click 
on the Add to Cart button to see the item, and the correct quantities, appear 
in the Mal's cart.

Congratulations, you've managed to produce a multi-priced and multi-product 
buy form. So far we've seen how we can set up simple text links that allow 
your users to add items into their shopping carts right through to quite 
complex multi-option forms that allow users to mix and match items and 
configurations. In our last example we'll look at how you can easily add 
optional items to your buy forms using both checkboxes and radio buttons.

Example 4: Using Checkboxes and Radio Buttons

Many items you may want to sell can be easily paired up with other items to 
produce multi-buy offers. For example an online store selling hi-fi equipment 
may want to offer a pair of headphones at half price on purchases of certain 
CD players. The discounted headphones may be enough incentive for many to 
make the purchase and the retailer is able to make two sales rather than one 
with the only disadvantage being the profit margin being eaten into slightly.

If you've been following the previous examples then you'll begin to see that 
there is a pattern developing in creating these form items. Typically we would 
either sketch a Mal's Buy Form Setup action to the page or attach the action 



to a table or HTML text box that will contain all of the form items for this 
purchase. The action itself holds all of the information in relation to the Mals 
user account, server address, etc. as well as any base price information. Any 
actions applied to the form elements within this area can either extend on 
this information or introduce new products, options or prices to the form. In 
practice the combination of form elements available for any one form are 
almost endless and it is often possible to find more than one way to produce 
the results you require using different form items or by setting them up 
slightly differently.

Start by sketching an enclosing HTML text box big enough to hold your form 
elements and apply the Mal's Buy Form Setup action by selecting Actions > 
Mal's Buy Form Setup from the Item menu.

Use the actions palette to enter your Mals Server address and User ID for 
this form. Add the product description and price to this enclosing action item. 
This will have the effect of setting a base price and description for all the items 
this form contains. From here we can choose to override this base value at 
any point using any of the 'child' form elements should we wish.

Insert a standard checkbox item into this form area by using the Insert > 
Checkbox menu item and apply the Mal's Quantity Field/Checkbox/
Radio action to it. Using the controls in the action's palette enter the number 
of items to be purchased when the user selects this item in the Quantity 
field. Typically this will be one (and is probably the figure the user will assume) 
but can be any number you wish.
Set the product number to the product these settings relate to. To start with 
we'll set this to one but as you add more and more products to this form item 
you'll want to increase this value to prevent one product's details overwriting 
another.

In the Product & price data section of the interface make sure that the Use 
info in parent form checkbox is unchecked and proceed to enter the details 
for this product in the remaining fields in the action's interface.
Add any further form elements (checkboxes, select lists, text areas etc.) as 
your form requires applying the appropriate Mals actions to these as 
previously described.

Finally add a standard form button into the text box by selecting the Button 
item from the Insert menu. You will now be able to preview the page in any 
web browser and check your handy work.



The Mal's Quantity Field/Checkbox/Radio action interface

A Word About Security
I hope that we've demonstrated over the course of this document that setting up 
shop with Mal's and Freeway has never been easier or as faster to achieve.
However, you will need to take precautions against those that would seek to 
tamper with your shopping cart code in the hope of purchasing your products 
or services at reduced rates.
To address this your Mal's online account offers an encryption option that, 
once switched on, will check the products match their correct values and 
decline the order if they do not.
Once enabled the Mal's site will also allow you access to a small block of code 
called a hash key which you will need to make a note of. This is simply an 
encrypted password that contains information about your store.

By adding this key to your store pages via the actions it allows all of the links 
to be encoded transparently without any need for further intervention.

We strongly suggest that you enable the link encryption options in both 



your Mal's admin area and the actions unless you are 'selling' free items such 
as product catalogues.

If the shopping cart receives an order where the information in the link or 
button does not match this hash code then the Mals shopping cart will simply 
refuse the order.

 

To have the actions encode the product links for you automatically you must 
first have the Link verification checkbox switched on and a valid hash 
code entered into the Key code text area.

Where do you get this key code? If you log into your secure administration 
section of the Mal's web site you will see an entry on the Shopping Cart Set-
up page called Link verification (on the right hand side of the browser 
window). Clicking on this link will open up a page with options to turn link 
verification on and off as well as section called JavaScript Button Creator.

At the top of this page you will find a warning about how turning link 
verification on can mean a lot of extra work as all of your links will need to be 
encoded and that the code has to be exactly correct for the store to accept 
any orders. Although this is quite true for everyone else because we will be 
using the actions we can rest in the knowledge that the actions will be doing 
all of this hard work for us automatically.

Enabling link verification



Tick the Test all my links... checkbox and press the Update Record 
button. When the page reloads scroll down t the JavaScript Button Creator 
section at the foot of this page.
 

Getting the key (or hash) code

Here we want to click on the Hash secret on it's own option. After entering 
your password and clicking on the Get validator button a new window will 
open with a single line of text in it containing your hash key code.

It should look something like this;
Hash Secret key for 1234567: 0ff541245d58fg54f7c2d3cf444cd9974c2

Save this file for later reference and keep it safe as you will need it while 
working with this store.

Enter this code (the part between the ": " and the end of the line) in the Key 
code text entry field in the action and press return. The action will now 
automatically encode the links generated for this item without further 
intervention.

Gallery

Listed below are just some of the ever growing number of sites that have 
made great use of these actions to build great looking online stores.

• Art B Arts [http://www.artbarts.com/]
• Beyond Blossoms [http://www.beyondblossoms.com/]
• Nixx Clothing [http://www.nixxclothing.com/]



• Whizz Ink [ http://www.whizzink.co.uk
or
https://coconut.sslsecuredsite.com/whizzink%2Dco%2Duk/]

If you would like to see your Mals enabled sites listed here and showcased on 
our web site feel free to get in touch (see below).

Further information

For more information about these, or other, actions for Freeway as well as 
updates and additional features please see our web site at;
http://www.freewayactions.com/

Everything we do is driven by the needs of our users so if there is something 
missing, unclear, or simply incorrect we want to hear about it.
Use the contact form on our web site at;
http://www.freewayactions.com/contact
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